2X launches the On Premise Edition of 2X MDM

An Easy and Affordable On Premise 2X MDM Solution

August 30, 2013 - 09:00am

Retain full control of sensitive location tracking data with 2X’s new On Premise Mobile Device Manager for Windows Server LONDON UK, 30 AUGUST 2013 – 2X, developer of the award-winning Windows VoIP PBX 3CX Phone System and mobile device management.

Better iOS support and Bing Maps added to the latest 2X MDM 6.4.5 build

Improved iOS Support Added to the New Version of 2X MDM

August 07, 2013 - 02:26pm

We pleased to announce the release of the latest version of 2X MDM (6.4.5) which has significantly enhanced iOS support. Administrators can now disable an iPhone's camera, as well as prevent users from accessing the Safari browser and iTunes. We're now

How-To
News
Help
Forum

Unable to log in Remotely

2X Remote Application Server allows the delivery of virtual desktops and applications from a central location, providing continuous availability, resource-based load balancing and complete end-to-end network transparency for administrators. This enables vendor independent virtual desktops & application delivery to users on any device, accessible from anywhere. The results are significant savings on administration and support.

Unable to log in Remotely

Postby airfrog » Mon Feb 07, 2011 2:24 pm

I have a 2X ApplicationServer set up to use SSL for Secure Client Gateway. I have a laptop with the 2x Client installed which can connect and access published applications and desktops fine when on the network.

I have set our broadband router to forward anything on port 443 to the ApplicationServer. When I am outside of our network I can connect to the ApplicationServer and it shows me the list of published applications. However, when I click on one of the published applications, I get the error:

[516] - The Client could not access the remote application.
The machine might be too busy to accept new connections or network problems are preventing your connection.
Please try connecting again later.



If I change the connection mode to Direct SSL Mode, I can still see the published applications, but get the following error when I click on any of them:

[260] - The specified remote computer could not be found.
Verify that you have typed the correct computer name or IP address, and then try connecting again.


The 2X logs do not suggest there has been any sort of error. When I open the client and it connects initially there is an entry in the log saying "Failed to get MAC address", but the entry after that says "Logon user 'user@domain' successfully". When I click on a published app to try and open it the log says "Client connection from address "xxx.xxx.xxx.xxx":port is tunneled to localhost (127.0.0.1):3389". When I log on to from within the network (where everything works fine) I get all of the same messages (minus the MAC address one). There are no extra "successful authentication" messages.

The Application Log on the laptop shows two 1001 Event IDs (Windows Error Reporting):

Fault bucket , type 0
Event Name: PCA2
Response: Not available
Cab Id: 0

Problem signature:
P1: TSClient.exe
P2: 8.1.941.0
P3: TSClient Application
P4: 2X ApplicationServer
P5: 2X Software Ltd.
P6: 200
P7: -1
P8:
P9:
P10:


I did a fresh installation of the 2X client on a separate Windows 7 laptop (that had not previous had the client installed) and encountered the exact same issues when connecting remotely: the client opens and displays the list of published apps, clicking on a published app produces the 516 error message. the 2X server logs show that the client connected successfully, the Windows Application Log on the laptop shows the TSCLIENT.EXE has reported an error.

I don't think it's a client configuration issue, because the same client can connect OK when inside the network. I don't think it's an authentication issue, because I can log in and see the list of published applications (plus I tried putting in an incorrect password and got a "logon failure" error). I don't think it's a problem with the port forwarding on the router as I can log in and see the apps, I just can't open them. It appears the client connects, logs in and then TSCLIENT.EXE crashes.

Does anyone have any suggestions as to what the issue might be?
airfrog
 
Posts: 2
Joined: Thu Dec 30, 2010 3:16 pm

Re: Unable to log in Remotely

Postby davidsaliba » Tue Feb 08, 2011 12:18 pm

Your client is version 8.1.941.0 from your notes what version is you server ?

Are there any crash dumps ?

Check the folder:
%APPDATA%\2XDumps\ (eg C:\Documents and Settings\user\Application Data\2XDumps)for any crash dumps (files *.dmp)

On windows 7 you might need to enable dumps attachment might help with that.

If you get a crash kindly open a ticket with support include your findings, eventlog and crash dump.
Include an explanation of the environment and also the type of NAT or firewalls you have (~since the issue occurs out of your network there might be something breaking the protocols in the process)

Hope this helps.
davidsaliba
 
Posts: 211
Joined: Mon Sep 07, 2009 9:01 am

Re: Unable to log in Remotely

Postby racgarcia » Tue Aug 02, 2011 6:41 pm

We are seeing the exact same issue...did you ever find a solution to the problem??
racgarcia
 
Posts: 1
Joined: Tue Aug 02, 2011 6:40 pm

Re: Unable to log in Remotely

Postby kimballwj » Fri Dec 07, 2012 1:27 am

I had the same problem (error 260 connection failure, despite getting to the published items folders OK) when using the latest (v10.5.1323) 64 bit client on Windows 8 (64 bit). Rolling back to the same 32 bit client (vv10.5.1323) fixed it for me. BTW, the 64 bit client has previously been fine for me on Windows 7 (64 bit).
kimballwj
 
Posts: 1
Joined: Fri Dec 07, 2012 1:15 am


Return to 2X Remote Application Server


Who is online

Users browsing this forum: Google [Bot] and 4 guests